• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
June 06, 2020, 07:14:12 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.


Leonarth's Engine Hacks

Started by Simpet, January 24, 2020, 06:01:59 pm

Simpet

Hi!
I've been trying to get the Leonarth's Engine Hacks applied to a fresh FFTA Rom (named FFTA_clean) and I'm not having any luck.

I downloaded Event Assembler and created a folder named "Event Assembler" in the root project folder and extracted the contents to that directory. (I couldn't locate an already made directory named Event Assembler.)
Extracted ups to the root folder as listed as optional.
Went through and edited ROM Buildfile.event a bit, not much though.

I ran the ROM Buildfile.event, and it created the FFTA_hack.gba as it was supposed to, but the created FFTA_hack.gba file was the exact same as the normal clean rom file.
Not sure what to do.

Thanks in advance for any tips or help. :)
  • Modding version: PSX & WotL

Blunderpusse

When you say it was the exact same, do you mean in terms of file size? Because the "FFTA_hack.gba" is supposed to have the exact same file size as the clean untouched one.
  • Modding version: Other/Unknown
"You sure are a keen observer of the obvious, kupo!"

Simpet

Nope.

What I mean is that when I started the FFTA_hack.gb version, the tutorial scenes aren't skipped and far as I can tell, none of the other hacks are applied either.
  • Modding version: PSX & WotL

Leonarth

When you run makehack the first thing that happens is that the rom gets copied.
If there are any errors, your rom would stay just like a vanilla rom.

Since you edited the buildfile it's possible that there's now errors, please run makehack and wait for it to complete, then show us if there are any errors.
(you could also show us your changes)

Other than that, make sure your Event Assembler is in the right location (and not somewhere like /Event Assembler/Event Assembler/)
  • Modding version: Other/Unknown

Simpet

Hey, thanks for the response!

I'm sure I'm doing something wrong, but I have no idea what...


I redownloaded the project folder and followed the instructions and this time I didn't edit anything at all in the "ROM Buildfile.event" file.

I ended up with the same result: It created a FFTA_hack, but the result was the exact same as vanilla.

Here's screenshots of the folders and of the cmd prompt.

https://i.imgur.com/ebHn2Gs.jpg
https://i.imgur.com/t8Fjdzk.jpg
https://i.imgur.com/b7MVEHV.jpg
  • Modding version: PSX & WotL

Leonarth

January 25, 2020, 05:13:20 pm #5 Last Edit: January 25, 2020, 07:33:21 pm by Leonarth
Makehack hasn't finished running in that image, please leave it open and allow it to run, at the end you'll either get error messages or a message saying "No errors."
It will take a few minutes.

Like I explained earlier, the first step the script does is to copy the rom, so the rom appearing does not mean the script has completed.
  • Modding version: Other/Unknown

Simpet

Oh. Man. Well.
That was it. I just wasn't waiting long enough for the script to finish. :x

Everything seems to be working exactly as it should be, now. Thanks very much for the help!  :v/: :v/:
  • Modding version: PSX & WotL