• Welcome to Final Fantasy Hacktics. Please login or sign up.
 

Need help with sprite

Started by deathspath, July 27, 2019, 02:30:19 pm

deathspath

July 27, 2019, 02:30:19 pm Last Edit: August 04, 2019, 05:19:44 pm by deathspath
so iv been working on my first sprite and i cant tell what the problem is but the sprite the shishi editor shows the sprite all messed up?
  • Modding version: PSX

Xifanie

It does? I haven't tried importing it, but I can't really see a major problem at first glance. I do see however that you're using the sprite's palette (1st row) for the portrait. The portrait's palette for Palette #1 is located the 9th row, where all your weird colours are. You have access to 16 (15 + background) unique colours for the sprite and as many for the portrait itself.
  • Modding version: PSX
Anything is possible as long as it is within the hardware's limits. (ie. disc space, RAM, Video RAM, processor, etc.)
<R999> My target market is not FFT mod players
<Raijinili> remember that? it was awful

Nyzer

Also, why is the portrait in the middle of the image?
  • Modding version: PSX & WotL
  • Discord username: Nyzer

Valkirst

  • Modding version: PSX
Completed Sprites
  • Discord username: Valkirst

Bonesy

i don't see sprite only a cheeto
  • Modding version: Other/Unknown
  • Discord username: Bonesy#9386

deathspath

yeah comes up as static when i try it in shishi and in the game itself also is the portrait not supposed to be in the middleish? thats where it is located in the games sprites when i extract them and pull them up in Graphics Gale the shishi reorders the sprites
  • Modding version: PSX

Xifanie

What version of Shishi are you using?
  • Modding version: PSX
Anything is possible as long as it is within the hardware's limits. (ie. disc space, RAM, Video RAM, processor, etc.)
<R999> My target market is not FFT mod players
<Raijinili> remember that? it was awful

deathspath

older version that opens spr files have a newer version but it errors on me every time i try to use it to open iso
  • Modding version: PSX

Xifanie

Yeah it would be way better if we figured out how you can run the newer version. What error are you getting?
  • Modding version: PSX
Anything is possible as long as it is within the hardware's limits. (ie. disc space, RAM, Video RAM, processor, etc.)
<R999> My target market is not FFT mod players
<Raijinili> remember that? it was awful

Elric

Quote from: Nyzer on July 27, 2019, 03:44:52 pm
Also, why is the portrait in the middle of the image?


Because that is the old format for sprite images. Hes using a ancient version of shishi for some reason
  • Modding version: PSX
<@Angel> Teach a man to fish and he'll open up a fishery to compete against yours.


Journey of the Five Youtube ChannelThe Lion War Current Status
  
Jot5 Leader :: Eventer :: OtherTLW Leader :: Eventer :: Other

Nyzer

Well, start taking screenshots. You're using an ancient Shishi and getting errors with opening .spr and ISOs when there's no reason you should be. Whatever's going on is so obscure we can't troubleshoot "the sprite is messed up". Details, pictures, specifics. For example, when Xifanie asks "what version" the right answer isn't "um, an older one". The more information you provide, the better help you can get, especially since no one wants to interrogate the info out of you.

Download the newest version from Tools in the wiki, as well.
  • Modding version: PSX & WotL
  • Discord username: Nyzer

deathspath

lol i found my issue was the smallest of things like you said the portrait was out of its boundary and too large causeing my unique colors to jump past limits i cut the extra off and now it runs good in shishi and all frames look good threw no errors this time
  • Modding version: PSX

deathspath

works in game just tested what a rush think i found a new hobby never would have guessed making sprites would be so addicting lol
  • Modding version: PSX

deathspath

still got to finish the last two heads and touch up the shadowing on the sprites but worked in game tho i do think i imported it over a type 2 so when i tested the arms detached a bit but still lol what a rush lol also my main issue is i was using some spr to bmp super outdated program not even a old shishi when i reimported with shishi it corrected the weird static issue i was getting at first so yeah was my bad being dumb using some 2004 conversion program that wasent even tailored for fft
  • Modding version: PSX

Valkirst

Didn't see this before, but why are you using lot of older programs? I fell like we're being trolled... or it's some elaborate joke... If you're serious I can help, we can use this to make Turks.
  • Modding version: PSX
Completed Sprites
  • Discord username: Valkirst