• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
February 05, 2023, 01:48:33 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.


Replies: 1
Views: 1,765

Replies: 0
Views: 2,352

Replies: 1
Views: 4,065

Replies: 5
Views: 6,412

Started by DarthFutuza


Replies: 3
Views: 2,632

Started by Emmy


Replies: 9
Views: 4,438

Replies: 2
Views: 2,160

Replies: 0
Views: 1,551

Started by nitwit


Replies: 5
Views: 2,616

Replies: 5
Views: 3,219

Replies: 18
Views: 11,821

Replies: 9
Views: 4,321

Replies: 1
Views: 1,929

Poll
Moved Topic

Locked Topic
Sticky Topic