• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
February 22, 2020, 08:45:50 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.


Map Editor: Ganesha 0.60 Released

Started by gomtuu, March 12, 2009, 01:40:11 pm

Cheetah

Oh I get what you are saying Gomtuu. That black polygon is just the black bit of the road sticking out the back of the map, which just happens to be right behind that part of the wall. So making it invisible from this angle will eliminate the problem.
Current Projects:

Xifanie

Yes, but the checkbox order made me stuck; I didn't know what was the problem as I couldn't find the right angles to hide.
It would be great if ganesha had another "view" mode for this kind of thing.
  • Modding version: PSX
<R999> My target market is not FFT mod players
<Raijinili> remember that? it was awful

deyama

Hello, everyone! I'm new to this commnity and hope someday I'll have an opportunity to contribute, but for now just wanted to say that you're doing a great thing here!

As for Ganesha, there is some error that prevents me from outputting PNG's... I just press O, browse the directory to put the file in and that's what I get ...



then it just shuts, when I press Enter.
Looked through the whole thread but seems like noone had encounered such an error before. Please forgive me if my question's stupid or something

gomtuu

Quote from: "deyama"As for Ganesha, there is some error that prevents me from outputting PNG's... I just press O, browse the directory to put the file in and that's what I get ...
Thanks for the bug report. I haven't seen that bug before, but I think I know what's causing it. It's weird that nobody else seems to have encountered it... I can't think of a reason why that part of the program would work differently on different computers.

I don't know when the next Ganesha release will be, but if you're feeling adventurous, I can give you some instructions that might fix this error. It would involve editing just a few lines of C:\Program Files\ganesha-0.60\game\ganesha\world.py. You'd need to use an editor that understands Unix-style line endings (e.g. Notepad++, not regular Notepad). Let me know if you want to try it.

deyama

Thanks for the soon answer, gomtuu! I'm still a dummy in coding (in fact has just began studying VB 6.0), but I think I want to try. So that I could make it run as soon as possible. Hope there's nothing too complicated and I can handle it ^__^

gomtuu

Come to think of it, it's much easier if I just post a patched world.py file. Just download this file, unzip it, and replace C:\Program Files\ganesha-0.60\game\ganesha\world.py with the unzipped world.py file. That should fix it, but let me know if it doesn't.

deyama

Sorry for bothering, but it doesn't T__T But the error message has changed to:

[spoiler][/spoiler]

gomtuu

Quote from: "deyama"Sorry for bothering, but it doesn't T__T But the error message has changed to:

What are you trying to use as the filename? From the error message, it sounds like you're using characters that aren't on this chart in the filename... I suppose Ganesha should support Unicode or something for filenames, but for now, can you try using only standard ASCII characters (or, more simply: just alphanumerics, underscore, and period)?

If you're already using standard ASCII characters, then that's a different story...

deyama

Yeah! The problem was solved!

I was pretty sure I'm using ASCII characters such as english letters or the default name that Ganesha gives to an export file (like "MAP025.7.png"), but you see, I was saving png's to the desktop, and as my path contained cyrillic characters Ganesha kept giving the error! Thank you, now it's working ^__^

And... there's a problem with map2gl as well. I'm using an executable version, so it needs no python library installed, right? But as I browse to a .GNS file it just closes. I think there something written in the command line, but it closes so fast, that there's no way I can screenshot it...  I think this problem is similar to what Allec wrote some posts earlier, but as he never found out what was realy causing map2gl to shut... I'm really very sorry for being a nuisance but is there something I can try to make it work? I know map2gl is discontinued, but as for now it's the only tool to display maps as they appear in game? (Ganesha displaying those in greyscale...)

EDIT: Sorry, now it's working. All a had to do was to run it from a CD or a virtual drive, but not from a local drive
EDIT2: Can run it from local drive as long as the other folders like "BATTLE", "WORLD" and so on are in the same folder. Seems like it's not just "MAPS" folder needed

White Knight Wiegraf

The program crashes in MAP036 upon selecting terrain (1,1) in Terrain Mode. This is what appears:

  • Modding version: PSX

Twinees

Hi White Knight Wiegraf,
Sorry for the late reply, I only just noticed your problem! (Might not want to bump a 6 year old thread next time though! :P)

I ran some tests and I also came across your issue, that particular tile reads as a 'None' value (hence why its saying it should expect a type of 'int'). I found the code mentioned and managed to brute force the slope type to Flat 0 for that particular tile (1,1) (which is what it should be?). Please check your private messages for the fixed version.

Hope this helped!
  • Modding version: PSX