• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
June 05, 2020, 01:31:39 am

News:

Please use .png instead of .bmp when uploading unfinished sprites to the forum!


New DTE for World.bin04 (but i was not changing it)

Started by badstapp, March 30, 2020, 03:43:37 pm

badstapp

March 30, 2020, 03:43:37 pm Last Edit: March 30, 2020, 04:01:38 pm by badstapp
Hi good afternoon all!

I had already some errors in the past, on other Tactext issue, i followed instructions correctly and it was solved in the past, as "Same version of tactext", "Saving on a patch", "Never changing already on the iso", "Erasing some japanese text" and others...but this persists

Background
World.bin 04 has "Shop/Save Text" it follows on "Quick Edit" the "Confirmation messages", which i translated almost a week ago, tested, patched ok good to go

Now i am edditing on "WORLD.LZW" the "17 Tutorial Menu" + "25 Tutorial menu" it follows "Quick Edit" the "Tutorial Menu"

Could someone take a liiitle look what might going on? (i did not editted any other events, only uses tactext, shishi battle sprites and patcher

Follow my patch from tactext (0.492) updated version: ATUAL V4.3.ffttext
  • Modding version: PSX

Nyzer

  • Modding version: PSX & WotL
  • Discord username: Nyzer

badstapp

Quote from: Nyzer on March 30, 2020, 05:38:35 pmFor Tactext, you should be using version 0.457.

How...really? It's a tougher work to copy/paste, but ok

I opened my currently tactext patch on 0.457, tried to patch my ISO and still the same issue happened, do you have an idea what should i do?

  • Modding version: PSX

Nyzer

Export the tactext file, close tactext, reopen it, and immediately patch it in?
  • Modding version: PSX & WotL
  • Discord username: Nyzer

badstapp

Quote from: Nyzer on March 30, 2020, 11:34:19 pmExport the tactext file, close tactext, reopen it, and immediately patch it in?

1st Test:
Opened my patch on tactext 0.492, saved (i don't know how to export, is there a way?) on a new name, closed. Reopened tactext 0.492, patched iso, same problem (World.bin04)

2nd Test:
Opened my patch on tactext 0.492, saved on a new name+, closed. Opened tactext 0.457, patched iso, same problem (World.bin04)

3rd Test:
Opened my patch on tactext 0.492, saved on a new name++, closed. Opened tactext 0.457, saved on new name+++, closed, reopened tactext 0.457, patched iso, same problem (World.bin04)

4th Test:
Opened my patch on tactext 0.457, saved on a new name++++, closed. Opened tactext 0.457, patched iso, same problem (World.bin04)

5th Test:
Opened my patch on tactext 0.457, patched iso, same problem (World.bin04)

I am a bit lost now..
  • Modding version: PSX

Aiolon

I cannot really tell you how to fix it but the issue is pretty easy to spot.

The problem is indeed located in WORLD.BIN 04
the thing is: you added A LOT of text to entries that shouldn't have any text on them.

I deleted all of the text you introduced in those blank entries and, guess what! It patched properly.
I don't know how you managed to patch that before without any issues. (Are you certain you did?)

You can even grab vanilla text file. Add something random to each of those blank entries and it will give you that same error.
It seems the ammount of text you can introduce in that sector is very limited.

  • Modding version: PSX
Wizzard: I have returned once again.
Chocobo: Wark?
Wizzard: yes.

badstapp

Quote from: Aiolon on March 31, 2020, 11:18:29 pmpretty easy to spot.

The problem is indeed located in WORLD.BIN 04
the thing is: you added A LOT of text to entries that shouldn't have any text on them.

I deleted all of the text you introduced in those blank entries and, guess what! It patched properly.
I don't know how you managed to patch that before without any issues. (Are you certain you did?)

You can even grab vanilla text file. Add something random to each of those blank entries and it will give you that same error.
It seems the ammount of text you can introduce in that sector is very limited.


Hi! Thanks for your answer!
I happened to try it further. Yes i am pretty sure i patched the world.bin04 after i finished edditing (and i always count the width to be fewer than vanilla, but of course i am human, i may have made a mistake)

I did exactly that, compared vanilla as mine. Found on "World.bin04", "World.lzw", "Battle.bin" and "Card.out2" there are same/similar texts "Error/Confirmation messages" as "Shop/Save text", with almost the same lines

Making this comparison i could spot one or another additional lines (as i am usually changes the "Quick edit" section"), on the blank spots, i think usually "Kanji input" and "input name" and some others...and it patched!!

When i came to post, you had post =D! But thanks for reading and helping!
Now double/triple check before edditing anything and avoid quick edit at all
Also comparing to vanilla before/after

Thaaaaaaaaanks for everything = SOLVED
  • Modding version: PSX