• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
October 28, 2020, 01:52:50 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.


Game Crashing at Dycedarg (Adremelek ENTD) after using FFTorgASM

Started by Randombartz, December 04, 2017, 05:19:29 am

Randombartz

Hello everyone. I was testing my modifications at FFT using FFTPatcher, FFTTactext and FFTorgASM and everything was going fine until I reached the Adremelek fight, in which the game crashes as soon as Dycedarg gets a turn. I tried ruling out everything and found out that the game only crashes if FFTorgASM ASMs have been applied. I tried checking hack by hack, removing conflicting ASMs and checking free space, but nothing seems to work, as soon as the ISO is patched with FFTorgASM (but not with Patcher or Tactext), it starts crashing at that specific fight. Any ideas on what might be causing it? Thanks for your attention.
  • Modding version: PSX

Emmy

  • Modding version: PSX

Angel

Hacks used as well as what you're running the game on. Not all emulators are equal, and many hacks don't work on Sony hardware.
  • Modding version: PSX
* Angel should quit being a lazy bitch
<@Elric> I agree to that as well

nyanyame nyanyajuu nyanyado no nyarabide nyakunyaku inyanyaku nyanyahan nyanyadai nyannyaku nyarabete nyaganyagame
At the end of the day, are we not all trapped inside lemons?

Randombartz

Most of the hacks I'm using are just to fix bugs in the original game, here goes the list:

Remove Forced Slowdown for Math
Swordskill element strenghten
Apply defense v2
Signed Y values
Formula 11: Magic Damage = Ma * (WP+Y)
Formula 13: White Winde (Pride)
Faith Constant
XA rewrite
Learn on Hit XX%
Broken/Stolen Items Bought at Fur Shop
Mighty Sword has XX% chance of breaking equipment
Blade Grasp fix
Blank Support ability over short charge adds 25% bonus skill
Elemental Fix v3
Maximum Level up
Weapon Battle Sprites and palettes edit (From Raven's Spreadsheet)
Wepaon Proc Rate (From Raven's spreadsheet).

As for the emulator, I'm using epSXE 1.9.0

The weird thing is that I tried to remove the hacks in batches (removed 1-5 first, then put then back and removed 6-10, etc), and it did not seem to fix the problem. I have also tried to put all hacks at once on a clean ISO (instead of adding them in different times), but the problem persisted nonetheless...
  • Modding version: PSX