• Welcome to Final Fantasy Hacktics. Please login or sign up.
July 14, 2020, 09:23:53 am


Don't be hasty to start your own mod; all our FFT modding projects are greatly understaffed. Find out how you can help in the Recruitment section.

FFT WotL Now on Android

Started by Aadarm, June 05, 2015, 09:40:39 pm


Any chance of getting something like LIOS for the Android version?


I hope so, I already have the game on my phone :) ! it's cool that it doesnt have the delay problem like on PSP and, more over the atk animation is faster than the PSX version.  i'd love an editor too and some hacking tools too.


It looks like the Android save file format is the same as the iOS save file format, so LiOS editor should work fine for the Android version.

The FFTSAVE.BIN file should be located in /data/data/com.square_enix.android_googleplay.FFT_en2/files/

If you try to edit the file directly on the device, you may get access errors, so I recommend copying the save file to your PC before doing any editing. As always, remember to back up your FFTSAVE.BIN before making changes.


cannot seem to find the alleged save file on android, nor can i find any relevant help.


Me neither i followed the path but there is no file in "Files"


I have a rooted phone and the game works fine on it, but The Files here referring to do not appear even after various searches on my phone and through the pc i did not see any of the files listed. The save location is either different, or require a special software to view :/ if you know something i dont please inform me otherwise.


In order to access the file on Android, your phone will need to be rooted. If you need information on doing that I suggest checking out the xda-developers.com forums or the appropriate reddit.com subreddit for your particular device.

Personally, I use an LG G3. It's shipped with KitKat 4.0 but has received the 5.0 Lollipop update. I personally am still on KitKat but I believe rooting is possible on almost all (if not all) Lollipop devices at this point.

Once you're rooted and have installed SuperSu, which allows you to give specific applications root access, then you will be able to access the area where the save file is stored.

After SuperSu is installed, install a root file manager (I personally use ES File Explorer for no particular reason other than it works) and after you give it root permissions (it will automatically request them from SuperSu once you attempt to access the non-sdcard portion of your device, i.e. the /data/data path).

Once you're in the /data/data/ path with root permissions, you'll see the folder and files I referred to. Copy the FFTSAVE.BIN to your SD card and then you can edit it from there and copy it back when you're finished.

You may have to enable viewing "hidden files" in ES File Explorer, but should not have to do so.

I've included a screenshot of the path below:


After typing a big wall-o-text about my experience I see some1 has already answered some of my questions, unfortunately SM-900V N900VVRUEOB6 seems to be the only Note 3 model that can't be rooted at the moment, guess I gotta put it on hold till some1 makes a Lios for unrooted androids or a root for my specific model of Note 3.

Gonna go out on a limb here... can some1 please provide a "vanilla" save from startup that I can edit to my desire. I'm hoping that even if I can't SEE the file, once I put the modified save in the right directory it should overwrite? All I really want is for JP not to decrease, and since theres no gameshark for this I'll Just have to edit the JP at startup and Stick with that team of characters. Funny thing is I just started a new playthrough with epsxe and fft rebirth mkII like 2 days before it was released but now that I got a taste of the sweet HD and reworked writing and animations I can't go back and have been trying to find a solution to mod this or root my phone ever since but its looking like a forlorn hope right now.

And yes, I've tried all the SuperSU and SuperSU Pro, Oneclickroot, Kingoroot23
, etc. spent entire days on this but like I said my model is the only Lollipop firmware that can't be done like that for some reason, all other Note 3s except SM-900V CAN be rooted in the above manner.


after re updating both my supersu and es file explorer, i found the file only by a button that was added on the new version of es file explorer called root explorer. then i went to data data and the folder and boom there it was !


I still cannot find it :( !!! my cellphone is rooted, Root Checker app say it is. But still cant find this data/data path;

The path i can find is Android/data/com.square_enix.android_googleplay.FFT_en2/files .... but there is nothin on files folder, it's empty.


I've installed both iExplorer and LIOS, but whenever I open the former and go to the Final Fantasy Tactics folder, it just shows "Loading" and nothing appears. Does this have anything to do with the recent iOS 8.3 update? It also says "This app does not have iTunes file-sharing enabled. On devices with 8.3, the developer of the app must enable file sharing in order to access the app contents.".


Ok everyone on android i have found a way that helps edit the game stats.  i have used it for gold and jp.  this can take some time if you never done this before.  I searched for memory editors that will work for lollipop and i found one.  you need root to do this tho i am using my lg -v496 that i got from tmobile on a fathers day deal.  Also my version of FFT is a cracked version.  I googled memory editors and found one called Gamekiller i dled it and it works very very well.  hxxp://game-killer.com/download/ this is the link change the xx's to tt's.  I you are not familiar with memory editors look up a tutorial for a program of old called game cih it work identical and let me edit the memory of my jp to 9999 and let me edit the amount of gil.  it can take some time to find the values but it definitely works. i attached a screen shot of the value that is for gold.  as you can see in the photo i am in the very begining of the game.  how i found this was i searched the value of my current gil.  i spent some gil searched again.  and repeated untill i found the value.  now once i found it all i did was add a zero at the end to make sure that the game didnt crash after wards.  and it didnt and i edited it to a massive amount and now im good.  baically you can do the same with jp all i did was make sure i had a couple hundred points prior to editing because the value might need to be lowered a few times.  hope this helps inbox me if you need help.  oh and does anyone have lag on the android version?


July 02, 2015, 11:38:06 am #12 Last Edit: July 02, 2015, 01:43:27 pm by Adizzzle
So I installed LionEditor and extracted my FFTSAVE.BIN, I then editted my save game, and replaced the file but no save games are available after replacing.

I then read I had to use a hex editor to copy line 27984 - 279c3 to the modded FFTSAVE.BIN from the original save game, but after completing that, and replacing again, no save games are available..


Anyone have any insight on this???
I tried many different permissions, but so far nothing is working.. Perhaps it's because I am using the LionEditor? Should I be using LiOS Editor?


Is there no way to use LiOS editor on android without having a rooted phone?


Yup maybe moded/hack apk to easy job lvl up


im happy to confirm that the ios editor works perfect with android saves!!

Funny how there is no GIL change option in the editor though.
So i end up equip the females with crocodile bags etc and sell them for high $$ :)



found the offsets for the war funds it is 2434 - 2437 change it to FF E0 F5 05

:mrgreen: :mrgreen: :mrgreen:


Hopefully someone can answer this..
But what happens if I for example were to change phones? how would I go about backing up my saves or some such if I cannot access them?

If I upgrade to the Galaxy S7 at some point id rather not have to go through the entire game grinding again..
Is there a way for google to back it up or what? im confused

As I'm new to actually owning a normal game on my phone I'm not sure as to how it would work
  • Modding version: Other/Unknown


That I'm actually not sure of. None of my games have saves that can be backed up or transferred, as all the save data is in restricted space and the only way to access that data is to root the phone and use a root-only app to get at the save data so it can be rescued. The problem with that is, rooting the phone deletes that data, so you need to already have root before you save your game. So, unless someone who actually has the game can confirm otherwise, you're screwed.
  • Modding version: PSX
* Angel should quit being a lazy bitch
<@Elric> I agree to that as well

nyanyame nyanyajuu nyanyado no nyarabide nyakunyaku inyanyaku nyanyahan nyanyadai nyannyaku nyarabete nyaganyagame
At the end of the day, are we not all trapped inside lemons?


That sucks.. aight thanks for the reply
  • Modding version: Other/Unknown