• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
July 15, 2024, 08:21:21 am

News:

Don't be hasty to start your own mod; all our FFT modding projects are greatly understaffed! Find out how you can help in the Recruitment section or our Discord!


Portrait and Formation Screen do not match what I imported in Shishi

Started by Khatmar, May 21, 2024, 01:40:30 pm

Khatmar

Hello, this is one of my first posts. Basically, I tried replacing Cloud with the custom Advent Children sprite that is available on hackticks and I even followed Celdias guide on spriting (this one here) but whatever I do, the changes I made just do not appear in game. I can get the battle sprite to change, but not the portrait and neither the formation screen sprite. They are always vanilla.

I even checked the ISO with other viewers (and other Shishi versions) and the portrait and formation screen sprite both appear to what I changed them to (but not in game).

Is it... save incompatible? Do I have to start a new game for the new sprite to show up? That doesnt make logical sense (but stranger things have happened). Could someone please help me out? Any assistance would be much appreciated.
  • Modding version: Other/Unknown

Nyzer

Quote from: Khatmar on May 21, 2024, 01:40:30 pmHello, this is one of my first posts. Basically, I tried replacing Cloud with the custom Advent Children sprite that is available on hackticks and I even followed Celdias guide on spriting (this one here) but whatever I do, the changes I made just do not appear in game. I can get the battle sprite to change, but not the portrait and neither the formation screen sprite. They are always vanilla.

I even checked the ISO with other viewers (and other Shishi versions) and the portrait and formation screen sprite both appear to what I changed them to (but not in game).

Is it... save incompatible? Do I have to start a new game for the new sprite to show up? That doesnt make logical sense (but stranger things have happened). Could someone please help me out? Any assistance would be much appreciated.

No, that's not it. Can you show us screenshots of each of the three files after you've imported them?
  • Modding version: Other/Unknown

Khatmar

Sure thing.

Here they are:



I followed Celdias tutorial to the letter. I have no idea what might be going on. The battle sprite works fine, it loads up without issue, however its the formation screen and the portrait which do not.
  • Modding version: Other/Unknown

Nyzer

I noticed that the title says Tweak. You're modding a modded version - one made with the finicky Valhalla editor. You should talk to Tzepish about that on Discord.
  • Modding version: Other/Unknown

Khatmar

  • Modding version: Other/Unknown

Khatmar

FYI

The issue was that the change was not reflecting when using the save/load state system of the PPSSPP, however when I used the in game save/load system, the changes worked. So that was an easy fix.
  • Modding version: Other/Unknown