• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
July 15, 2024, 08:27:22 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen, RetroArch, and Duckstation are recommended for playing/testing, pSX is recommended for debugging.


Help!

Got a question? COME HERE FIRST! Moderator: Jumza.

Replies: 0
Views: 182

Replies: 2
Views: 793

Started by Riky


Replies: 3
Views: 1,028

Poll
Moved Topic

Locked Topic
Sticky Topic