• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
October 17, 2021, 12:23:42 am

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.


Help!

Got a question? COME HERE FIRST! Moderator: Jumza.

Started by mpelos


Replies: 11
Views: 2,277

Replies: 2
Views: 569

Started by garga


Replies: 2
Views: 1,537

Poll
Moved Topic

Locked Topic
Sticky Topic