• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
September 27, 2021, 02:33:27 pm

News:

Don't be hasty to start your own mod; all our FFT modding projects are greatly understaffed. Find out how you can help in the Recruitment section.


Unable to Get Job Lvl 8 Geomancer on WotL 1.3.3

Started by BrizzleSizzle, April 04, 2021, 11:24:15 pm

BrizzleSizzle

Title.  So I think I may have hooped myself by mastering Geomancer (buying all the skills) before it was actually level 8.  Anyone else run into this problem?  I have over 3000 JP at level 7 currently.  Is this even needed in this version to unlock Dark Knight?  I can't find an accurate source of info for the job requirements.  They also seem to be quite different from both WotL and vanilla.  Please help!!!
  • Modding version: WotL

Elric

Quote from: BrizzleSizzle on April 04, 2021, 11:24:15 pmTitle.  So I think I may have hooped myself by mastering Geomancer (buying all the skills) before it was actually level 8.  Anyone else run into this problem?  I have over 3000 JP at level 7 currently.  Is this even needed in this version to unlock Dark Knight?  I can't find an accurate source of info for the job requirements.  They also seem to be quite different from both WotL and vanilla.  Please help!!!

We don't support 1.3 here
  • Modding version: PSX
<@Angel> Teach a man to fish and he'll open up a fishery to compete against yours.


Journey of the Five Youtube ChannelThe Lion War Current Status
  
Jot5 Leader :: Eventer :: OtherTLW Leader :: Eventer :: Other