• Welcome to Final Fantasy Hacktics. Please login or sign up.
 
April 16, 2024, 12:36:51 pm

News:

Please use .png instead of .bmp when uploading unfinished sprites to the forum!


Editing Existing Patch

Started by alexkost, September 15, 2022, 05:12:36 pm

alexkost

I want to dip my toe into the world of FFT hacking. I've been reading various threads on here and reddit to try and learn the basics.
If I understand correctly, FFTPatcher can be used to both create new patches and to modify existing ones. I wanted to start out by making some small changes to FFT: Emergence, but every time I try to open the patched iso under the PSP menu, I get the following error:
"an error of type FTTPatcher.Datatypes.FTTPatch+LoadPatchException occured:
Could not load patch"
Am I missing something small, or just going about this all the wrong way?

Thank you,
~Alex
  • Modding version: WotL

darkskyx

I never had that error but you may be doing something wrong, like opening a PSX ISO.
Keep in mind you have to patch an EUR ISO for the Emergence patch and then you can edit it.
Maybe it is not opening because you may have patched an US ISO, it shouldn't be failing. Try to use the lastest version of the program too.
Also here's a Useful FAQ I did while working on my hackmod https://ffhacktics.com/smf/index.php?topic=12942.0
  • Modding version: WotL

✪ Emergence 2 for PSP (EN/ES) - Play it now! ✪
A vanilla+ experience for PSP. Actual patch: 1.0+. More fixes in v1.1!
  • Discord username: darkskyx#9825