• Welcome to Final Fantasy Hacktics. Please login or sign up.
April 16, 2024, 01:10:08 pm


Use of ePSXe before 2.0 is highly discouraged. Mednafen, RetroArch, and Duckstation are recommended for playing/testing, pSX is recommended for debugging.

[SOLVED] Black screen after finishing Chapter 2 (TLW 2.03, QoL1.13b)

Started by Scott2bReal, September 13, 2022, 02:48:00 pm


September 13, 2022, 02:48:00 pm Last Edit: September 20, 2022, 03:21:33 pm by Scott2bReal Reason: Issue resolved
Hi everyone! First off I'd like to say a huge thank you to everyone works on these mods. It's all way over my head but I really appreciate the work you all put in.

I recently started a fresh playthrough using the latest versions of TLW (2.03) and Xifanie's QoL Pack (1.13b). I first patched my fresh image with TLW, then the movies (as instructed in the README), and then put the QoL patch on top of that. Everything was working great until I got to the end of chapter 2. After finishing the battle, the scene in Zeltenia Castle plays out, Delita kills the guy and the screen fades to black.

After that, nothing happens! The music keeps playing but the screen stays black. I'm using the latest version of Duckstation on Linux, and have also tried on Windows 10 with Duckstation as well as psxfin. When using psxfin, text will scroll after the scene in the castle, but then the same thing happens.

Apologies if I've done something obviously wrong or this comes up a lot. I did some searching but couldn't find anyone describing this exact issue. Happy to provide any debugging info, and thanks in advance!
  • Modding version: PSX


You probably haven't done anything wrong, I'm just way too sick to investigate/fix it.
2.03 has just released, so I haven't had the chance to test or code yet.
  • Modding version: PSX
Love what you're seeing? https://supportus.ffhacktics.com/ 💜 it's really appreciated

Anything is possible as long as it is within the hardware's limits. (ie. disc space, RAM, Video RAM, processor, etc.)
<R999> My target market is not FFT mod players
<Raijinili> remember that? it was awful


Thanks for the reply, I didn't mean to rush you! Sorry to hear you're sick :( I loooove the QoL pack, so thank you for that too! The zodiac compatibility checker is amazing and idk if I can go back to playing without being able to cancel moves.

I'd love to provide whatever support I can. I see that you provided the source for the QoL, so I'll poke around the tutorials and see if I can figure out how to test things myself!
  • Modding version: PSX


For anyone reading this in the future and looking to use stuff from the QoL pack with TLW 2.03, it looks like specifically the cross skip hack is what is causing this problem. I didn't figure this out myself but found discussion on the Discord describing it.

I was able to manually apply everything from the QoL pack (excluding cross skip) using FFTorgASM, and these instructions from Nyzer found on the Discord were very helpful:

Quote from: undefinedYou would be best served to download the TLW Resources, download the QoL .zip file, and move the files from QoL v1.13b\QoL ASMs\XmlPatches to The Lion War 2.03 Resources\6. TLW ASM (Patch Last)\ASM (FFTP .495 B1)\XmlPatches\PSX
Then in The Lion War 2.03 Resources\6. TLW ASM (Patch Last)\ASM (FFTP .495 B1), run the program FFTorgASM.

OrgASM will show a list of all the file names of the .xmls you just imported - you can check every specific hack you want to include in those five files, and then choose Patch, patching it to your game (which you should make a backup copy of before patching just in case).

I'm now into Chapter 3 and having a blast. Thanks to Elric and everyone from the TLW team for an awesome mod and Xifanie for the great QoL additions!
  • Modding version: PSX


If you apply the Event Instruction Upgrade hack from the TLW Resources, that will fix what Cross Skip broke.
  • Modding version: Other/Unknown