• Welcome to Final Fantasy Hacktics. Please login or sign up.
November 26, 2022, 01:55:23 pm


Please use .png instead of .bmp when uploading unfinished sprites to the forum!

What eventually let me patch WotL with FFTacText

Started by Vir, May 26, 2014, 06:18:00 pm


I kept getting the same error messages we see all about the forums here:

"Object reference not set to an instance of an object" with TacText .457

And with .482, which I had been using these two weeks before trying to apply the patch, I'd get

"DTE for BOOT.BIN 5 failed."
"DTE for BOOT.BIN 7 failed."
"DTE for BOOT.BIN[some hex] failed."

I followed advice from various good posters:

used a new, unpatched ISO

resaved my .ffttext, closed, opened, tried again

deleted all kanji and other extraneous text I could find in every accessible file...

did all these same things in .457 which (for people who can't find it) I found here http://ffhacktics.com/smf/index.php?topic=7837.0

importing the original text from the clean ISO so I could watch that not patch either

The problem was unremitting through every variation of the above and probably some stuff I've forgotten these 18 hours: DTE error in .482, object reference error in .457. The only thing I did not try (in case anyone still working on the problem is interested in what all advice I can remember finding) is refilling all the cells I'd just cleared which worked for Barren here:


In my case none of this appeared to matter

I opened .457 (don't know if that mattered)

I imported the all text from a clean PSP ISO

I opened .482 and loaded my .ffttext

I copied all my changes from the .482 window into the corresponding .457 window cell by cell
Every two categories of cell I modified (ie, after copying over guns and knightswords) I patched the my FFTPatcher-modded ISO from the .457 window which was accessing it directly

At no time did I try again to let a .ffttext patch patch the iso

shima in the link above says that worked for him 9/10 times; I never had any error message saving it this way after several hours and probably ~15 saves

I didn't delete any kanji or extraneous text from this .457-imported ISO

So, in my case, it didn't matter if I saved to a clean ISO. It didn't matter that I added text without deleting any. The only thing that apparently mattered was that I didn't try to apply an .ffttext patch.

Two caveats:

I also tried running the programs as administrator. I don't know if I was still running as such when they eventually worked.

And lastly because it seems to me VERY IMPORTANT, if you use this method, remember NOT to close .457 before you're done testing or you may have to paste everything in again. (You might be able to load from your patched ISO, but why find out?) EDIT: I just tested this and it reverted to the same problem. Apparently you have to load a clean ISO in the first place, but it doesn't matter what you save to.


This post should be pinned... Very useful. I was getting errors everytime but your method worked for me when I tried it 1 year ago. Now I will make the final changes to my hackmod so let's pray everything will work fine.
  • Modding version: WotL

✪ Emergence 2 for PSP (EN/ES) - Play the beta now! ✪
(It only lacks skills descriptions and some changes in JP skills)