Please login or register.

Login with username, password and session length
Getting pSX 1.13 to work on Linux  (Read 7624 times)
Pages: [1]
SaGa Frontier Hacker
Pickle Girl Fanboy [Posts: 1482]
  • View Profile
  • Bio Research Lab
  • share
  • [April 02, 2012, 09:00:18 PM]
Getting pSX 1.13 to work on Linux
« on: April 02, 2012, 09:00:18 PM »
This assumes you have a Linux distribution derived from Debian.

All credit goes to the posters in the following thread:
http://ubuntuforums.org/archive/index.php/t-928546.html

1. Get the dependencies.  Open a terminal and type this, if you use Debian:
Code: [Select]
sudo aptitude install libgtkglext1-dev Or this, if you use Ubuntu:
Code: [Select]
sudo apt-get install libgtkglext1-dev
 2. Moving stuff around.   Enter the following commands in terminal:
 
Code: [Select]
mkdir -pv ~/.pSX/cards
 touch ~/.pSX/cards/1.mcr && touch ~/.pSX/cards/2.mcr
 cd $HOME
 wget http://easyweb.easynet.co.uk/~david.s/saturn/images/Playstation_icon.gif
 sudo mv Playstation_icon.gif /usr/share/pixmaps
 wget http://psxemulator.gazaxian.com/pSX_linux_1_13.tar.bz2
 tar xjvf pSX_linux_1_13.tar.bz2
 sudo mv pSX /opt

3. Get a PS1 BIOS file, called scph1001.bin.  Google is your friend.  When you find it, put it in your home folder, and then type the following in the terminal (this assumes you have gedit installed):
 
Code: [Select]
sudo mv scph1001.bin /opt/pSX/bios
 sudo gedit /usr/bin/pSX
This should open gedit.  Paste the following into gedit, save it, and then close it.
Code: [Select]
#!/bin/bash

cd /opt/pSX
 ./pSX

Now when you want to use pSX, just open terminal and type pSX.

 5. What, pSX crashed!  Enter the following commands in terminal.
Code: [Select]
sudo chmod 755 /usr/bin/pSX 
 6. Now to add it globally to your menu.  (Doesn't work for me.  Meh.):
 
Code: [Select]
sudo gedit /usr/share/applications/pSX.desktopThis will open a file in gedit.  Paste this in it and save it.
 
Quote
[Desktop Entry]
 Type=Application
 Version=1.0
 Encoding=UTF-8
 Name=pSX Emulator
 Comment=Play Playstation games on your PC!
 Icon=/usr/share/pixmaps/Playstation_icon.gif
 Exec=pSX
 Terminal=false
 StartupNotify=false
 Categories=Game;Emulators;

 7. If pSX still won't work.  It's probably Pulse Audio.  You need to tell pSX to not use Pulse Audio.  Here's how to do it.
Code: [Select]
sudo killall pulseaudio^Kills Pulse Audio for the moment.

Code: [Select]
sudo ./pSX^Runs pSX as root

Now, while pSX is running, get past the "Select Language" prompt and then go to File, and then to Configuration.  Select the "Sound" tab in the configuration pop-up menu.  Switch the "device" from default to whatever the other option is, which should be your soundcard (something like plughs: 0,0).

Make sure that what you selected has "Analog" somewhere in it, or else you won't get sound.

Run the following:
Code: [Select]
gksudo gedit /root/.pSX/psx.iniFind the "Device" string under the [Sound] section, and copy it.  It should be about 8 non-sense letters and numbers, all in a row.

Now paste that string to the "Device" string, under the [Sound] section, in /.pSX/psx.ini.  If you don't have a psx.ini in that folder, then run pSX and cancel just after choosing language, or on the bios select prompt.  pSX should save it's settings then.
French Maid
Xifanie (Webmistress) [Posts: 4386]
  • View Profile
  • Final Fantasy Hacktics
  • http://steamcommunity.com/id/Xifanie
  • share
  • [May 27, 2012, 09:41:50 PM]
Re: Getting pSX 1.13 to work on Linux
« Reply #1 on: May 27, 2012, 09:41:50 PM »
pSX 1.13 Windows + Wine VS pSX 1.13 Linux

Windows version + Wine:
- Major sound issues that may temporarily/completely screw up your sound output, or even mute it (for the emulator itself). Messing with sounds settings may, or may not make a difference. There is no miraculous settings if this happens to you.
- Seems very stable otherwise

Linux version:
- "sound: underrun" when the processor is using too much resources, a very short sound pause, but also very annoying. This happens to me when I'm moving the mouse too much, using other programs or just turboing. This IS caused by pulseaudio.
- "Pause when not focused" does not work
- Uses fewer resources
- No debugger

Note that those are all from my personal experience. With that said I'm considering getting a new emulator altogether... the lack of debugging really hurts.

***About the sound issues: they are caused by pulseaudio which doesn't seem to work well with Wine. After removing PulseAudio (including the volume controller), installing OSS4 (I'm not sure this is necessary), and finally installing Gnome ALSA Mixer, all my sound problems were gone. Kill the pulseaudio process too before trying ALSA, and enjoy. If you manage to do this, then I'd say pSXfin 1.13 + Wine all the way.
« Last Edit: May 28, 2012, 08:13:48 PM by Xifanie »
    • Modding version: PSX
  • <R999> My target market is not FFT mod players
    <Raijinili> remember that? it was awful
    SaGa Frontier Hacker
    Pickle Girl Fanboy [Posts: 1482]
    • View Profile
    • Bio Research Lab
    • share
    • [May 28, 2012, 09:54:28 PM]
    Re: Getting pSX 1.13 to work on Linux
    « Reply #2 on: May 28, 2012, 09:54:28 PM »
    Note that those are all from my personal experience. With that said I'm considering getting a new emulator altogether... the lack of debugging really hurts.
    What other emulator?  PCSX-R is a massive pain in the ass, and it's debugger is awful.
    osirisgothra [Posts: 1]
    • View Profile
    • share
    • [November 28, 2014, 10:56:08 AM]
    Re: Getting pSX 1.13 to work on Linux
    « Reply #3 on: November 28, 2014, 10:56:08 AM »
    Just a note about killing pulseaudio... by default it likes to respawn. At the very least you must change /etc/pulse/client.conf, in there there are 2 lines, make them look like this:

    autospawn = no
    daemon-binary = /bin/true

    Otherwise no matter if you use killall or (preferably) 'pulseaudio --kill' you will get the respawn.
    Another note, DONT USE PASUSPENDER, even if you suspend pulseaudio, pSX WILL try to use it and crash anyway. The only way to prevent it from using pulseaudio is to kill the daemon since it looks for the process in the /proc and finds it running even if suspended.

    One more thing: for 64-bit linux users, you must install the libgtkglext1:i386 and libglade2-0:i386 libraries. You will know right off if you didnt because you will get 'wrong ELF class' errors. Also, if you cant get the libraries to work, or you are trying to manually use them, you'll have to 'export LD_LIBRARY_PATH=<path_to_your_libraries>' to ensure that pSX looks for them there, this can be more than one place, separate multiple places with a colon (:) and your good to go.

    Thanks alot for the one golden suggestion which was to actually try to do this again. pSX has always worked better for me than pcsx, so when I switched to linux, even under wine, I was sad that I couldn't use it (and pcsx does not play Valkyre Profile at all, well at least not after the first part of the intro). So I was happy to hear someone finally had some luck with it. With that and some experimentation on my own, I was able to get it to work on my box, which is currently running Ubuntu (Kubuntu) 14.04 64-bit, with most of the 14.10 backports installed. I am a software developer so if anyone has more questions or just can't get it to work you can email me via this site.

    Pages: [1]