Please login or register.

Login with username, password and session length
Advanced search  

News:

Use of ePSXe before 2.0 is highly discouraged. Mednafen/RetroArch is recommended for playing/testing, pSX is recommended for debugging.

Pages: [1]
Cerabow [Posts: 13]
  • View Profile
  • share
  • [October 30, 2019, 11:56:54 PM]
Issue with PPF run on pSX 1.13 using Shishi expansion
« on: October 30, 2019, 11:56:54 PM »
So I've been banging my head on this for a little while and tried multiple things from multiple directions and still can't seem to make headway, so I must be doing something wrong or its a known issue.

Context
I've been working on a mod for a while now and a new bug that I hadn't seen before.
I slowly eliminated all of my patch content, Attack.OUT / TEST.OUT modifications, ASM hacks, FFTPatcher data, FFTactext data... and both individually and combined I can make a working PPF that doesn't bug out/hardlock. I was able to narrow it down to Shishi seemingly being the cause when using a PPF.

I've manually expanded a vanilla game image to create a PPF per Xif's wonderful tutorial here: http://ffhacktics.com/smf/index.php?topic=7457.0 . I use the manually expanded game image as my Original File in PPF Studio and the Patched File is nothing more than the same vanilla game image file pre Xif expansion, only I opened it and restructured it via Shishi's for more sprite room.

So for my troubleshooting, when making a PPF I use...
Vanilla base image: manually expanded via HEX to match file size of patched image
Patched base image: vanilla image restructured using Shishi
The images are not modified in any other way.

Problem
For some reason, in pSX 1.13 (I haven't been able to replicate this in other emulators or even in pSX until recently), when any event loads with Worker 8, the game just says "Now Loading..." indefinitely. I can easily replicate this with any late-game save file by simply loading the Brave Story event "Steel ball found!" Alternatively if you go to the Nelveska Temple fight, after the Squad screen and the map name displays, the game just hardlocks at a black screen.

Note that if I open the Shishi expanded game image in pSX, the scenes will load and work properly.
However, regardless of which game image I use (shishi expanded or PPFed), I do see a number of errors in the psxfin console:
I have seen these errors before and they have typically been benign, but maybe I should be worried about them? For reference the true vanilla image does not show these errors during that particular scene.

Has anyone else experienced this sort of behavior? I'm at a loss for what I could be doing wrong. I've tried multiple vanilla game image bases in different "formats" (because I know it's all the same data, but i wanted to try) and can't seem to get a patch to not lock up the pSX emulator now. I even tried an older version of Shishi (483, currently using 492). I did a little searching on the forums, but couldn't find any results, but my search-fu might be lacking.

I hope this paints a clear enough picture. Any help or guidance is appreciated!

    • Modding version: PSX
  • --
    Robert'); DROP TABLE Students;--
    French Maid
    Xifanie (Webmistress) [Posts: 4468]
    • View Profile
    • Final Fantasy Hacktics
    • http://steamcommunity.com/id/Xifanie
    • share
    • [October 31, 2019, 12:55:35 AM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #1 on: October 31, 2019, 12:55:35 AM »
    Which programs are you using to create and patch the .ppf? Because the culprit has to be one of those two at this point.

    And those errors are completely benign to my knowledge; it's just the 4 byte value for the number of sectors used on the CD-ROM isn't edited by Shishi, but if you ever burn the CD, I'm pretty sure it's one of those things that is automatically recalculated by any program.

    • Modding version: PSX
  • <R999> My target market is not FFT mod players
    <Raijinili> remember that? it was awful
    Cerabow [Posts: 13]
    • View Profile
    • share
    • [October 31, 2019, 01:10:07 AM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #2 on: October 31, 2019, 01:10:07 AM »
    I'm using PPF-Studio 1.01b and ppf-o-matic3, both Windows versions and to my knowledge the latest versions (at least on the site they are).

    And good to know about the errors.

    • Modding version: PSX
  • --
    Robert'); DROP TABLE Students;--
    French Maid
    Xifanie (Webmistress) [Posts: 4468]
    • View Profile
    • Final Fantasy Hacktics
    • http://steamcommunity.com/id/Xifanie
    • share
    • [October 31, 2019, 01:25:43 AM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #3 on: October 31, 2019, 01:25:43 AM »
    1) Actually, just to make sure... you used the same ISO for both the Shishi expanded and 00 bytes padded ISO, right? Two ISOs from different sources would totally break things.
    2) Can you tell me the size in bytes of the Vanilla Shishi expanded ISO, of the 00 padded ISO, and of the patched ISO?

    • Modding version: PSX
  • <R999> My target market is not FFT mod players
    <Raijinili> remember that? it was awful
    Cerabow [Posts: 13]
    • View Profile
    • share
    • [October 31, 2019, 02:01:37 AM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #4 on: October 31, 2019, 02:01:37 AM »
    1. Yes, I extracted both copies from the same rar. I typically only use the one base image. I would expect things to break horribly when generating the PPF if I used different ISOs. But I should be able to APPLY the PPF to any vanilla ISO correct? I've tested this and this is generally true.

    2. Sure. The sizes (not size on disk) are:
    Vanilla 00 padded ISO: 552 701 184
    Vanilla Shishi expanded: 552 701 184

    oh. well that's interesting...
    Patched ISO: 552 701 179

    So I tried another quick experiment and applied one of my older patches to a vanilla ISO using a totally separate set of ISOs, the ones which I have been using this whole time before I found this issue, and it showed the same anomaly:
    Vanilla 00 padded ISO: 552 701 184
    Shishi expanded mod ISO: 552 701 184
    Patched ISO: 552 701 179

    What could cause the patched ISO to be 5 bytes smaller? (I'm hoping I'm just being dumb about something and it's an easy fix.)

    Should I maybe try using the PPF Full Distibution zip on the Tools page? It looks like it has PPF-o-matic, but also some other tools that might work?

    • Modding version: PSX
  • --
    Robert'); DROP TABLE Students;--
    The Puppet ---Master---
    Elric (Overseer) [Posts: 4268]
    • View Profile
    • Youtube Channel
    • http://steamcommunity.com/id/Bones42
    • share
    • [October 31, 2019, 05:46:44 PM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #5 on: October 31, 2019, 05:46:44 PM »
    You likely forgot to change the very last byte in your padded iso to something other than zero, before making your ppf.

    Change the last byte in the padded iso to 01 instead of 00 and try again (dont expand the padded iso with shishi)

    This issue specifically, causes the issue with Worker 8. We had this issue in the initial release of Jot5
    « Last Edit: October 31, 2019, 08:09:19 PM by Elric »
    • Modding version: PSX
  • <@Angel> Teach a man to fish and he'll open up a fishery to compete against yours.
    Journey of the Five Youtube ChannelThe Lion War Current Status
      
    Jot5 Leader :: Eventer :: OtherTLW Leader :: Eventer :: Other
    Cerabow [Posts: 13]
    • View Profile
    • share
    • [October 31, 2019, 08:17:14 PM]
    Re: Issue with PPF run on pSX 1.13 using Shishi expansion
    « Reply #6 on: October 31, 2019, 08:17:14 PM »
    Tiny detail is tiny. That absolutely corrected the problem both with the file size not matching exactly.

    And I just loaded the Worker8 scene without issues!

    Thanks a bunch both Xif and Elric! Sharing your breadth of knowledge is always SUPER appreciated!
    Could someone update Xif's original post here: http://ffhacktics.com/smf/index.php?topic=7457.0 with a note at the bottom, specifically mentioning to update the 01 bit and that it is not mentioned in the video?

    Problem Solved
    When manually expanding the vanilla ISO to match file sizes, the very last HEX bit should be changed to 01, not 00 (like all the rest of the padded values).

    • Modding version: PSX
  • --
    Robert'); DROP TABLE Students;--
    Pages: [1]