Please login or register.

Login with username, password and session length
Advanced search  

News:

Please use .png instead of .bmp when uploading unfinished sprites to the forum!

Pages: [1]
Go then. There are other worlds than these
yamish [Posts: 31]
  • View Profile
  • share
  • [February 11, 2019, 09:26:36 PM]
FFTorgASM appears to be doing nothing [solved]
« on: February 11, 2019, 09:26:36 PM »
I am using the latest version of the Patcher Suite.
I am modding the PSX version.
The ISO being used is a bin/cue that i confirmed as usable via md5 against the thread that lists md5s
The ISO is not read only
FFTPatcher successfully patches the ISO
FFTorgASM has been run regularly and with admin privileges

When using FFTorgASM to attempt to apply patches, nothing happens. They are selected, bin is selected, no confirmation nor error messages nor anything when clicking to apply it. Open up the iso in FFTPatcher to see if formula 11 is no longer blank (what im using to quickly see if it is succeeding) and it remains blank.

I've looked everywhere and can't find a single thing I'm missing or have done wrong. Any insights into this?
« Last Edit: February 13, 2019, 04:39:30 PM by yamish »
    • Modding version: PSX & WotL
    • Discord username: riggz raggz
  • Glain [Posts: 523]
    • View Profile
    • share
    • [February 11, 2019, 10:15:09 PM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #1 on: February 11, 2019, 10:15:09 PM »
    The formula labels in FFTPatcher don't read anything from the actual formula code in the game, so that doesn't work as a quick test.  :D

    You'll have to try testing the behavior in-game.

    Generically, you can also see whether or not the timestamp updates on the BIN file when you apply a patch.
    Go then. There are other worlds than these
    yamish [Posts: 31]
    • View Profile
    • share
    • [February 12, 2019, 01:11:52 AM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #2 on: February 12, 2019, 01:11:52 AM »
    Ah, i thought if i opened the iso itself it would show the formula. Thanks for clearing that up.

    And i didn't check timestamp cause...ok look i smoked a lot today

    So FFTorgASM gives no success/fail message upon tunning?
    Nyzer [Posts: 1102]
    • View Profile
    • share
    • [February 12, 2019, 04:52:06 AM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #3 on: February 12, 2019, 04:52:06 AM »
    FFTP has basically never drawn anything from the ISO; I learned that a long time ago just from modding my own personal patch. Always had to keep a note of what IDs were what changed skillset or name or whatever.

    • Modding version: PSX & WotL
  • Go then. There are other worlds than these
    yamish [Posts: 31]
    • View Profile
    • share
    • [February 12, 2019, 08:24:36 PM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #4 on: February 12, 2019, 08:24:36 PM »
    Using epsxe for android

    Ok so it appears FFTorgASM doesn't give any kind of indication that has successfully applied anything.

    I applied two ASM hacks, the one that changes formula 11 to MA*(WP+Y) and the one that says All formulas apply element (v2)

    This is the only modification thus far.

    All goes well with opening sequence, Gaf and Agr converse, then when Gaf goes to take his first turn, epsxe crashes. Behavior is normal with an a unaltered iso.

    Are one of these reliant on another ASM hack to be in place? Is there a list somewhere of conflicting ASM hacks that aren't readily apparent? Am I just dumb?
    Glain [Posts: 523]
    • View Profile
    • share
    • [February 13, 2019, 01:05:30 AM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #5 on: February 13, 2019, 01:05:30 AM »
    That should have worked.  It turns out... there was a bug in my elemental hack!  Thanks for reporting the issue.  I've fixed the problem and uploaded a new zip in my ASM thread.
    Go then. There are other worlds than these
    yamish [Posts: 31]
    • View Profile
    • share
    • [February 13, 2019, 04:27:56 AM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #6 on: February 13, 2019, 04:27:56 AM »
    Awesome! I'll give it a go tomorrow and report back.
    Trying to learn it all...
    Nizea [Posts: 7]
    • View Profile
    • share
    • [February 13, 2019, 02:31:59 PM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #7 on: February 13, 2019, 02:31:59 PM »
    FFTP has basically never drawn anything from the ISO

    This does not match my experience.

    Perhaps it was true for old Patcher versions prior to my FFT-hacking days...
    Have you continued to verify this behavior as new versions were released?
    « Last Edit: February 13, 2019, 02:48:02 PM by Nizea »
    • Modding version: PSX
  • There are 10 kinds of people in the world; those who know binary, and those who don't.
    Nyzer [Posts: 1102]
    • View Profile
    • share
    • [February 13, 2019, 03:26:06 PM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #8 on: February 13, 2019, 03:26:06 PM »
    Are you saying that when you put custom formulas in the Patcher automatically reads the change and reports it correctly?

    • Modding version: PSX & WotL
  • Trying to learn it all...
    Nizea [Posts: 7]
    • View Profile
    • share
    • [February 13, 2019, 04:17:24 PM]
    Re: FFTorgASM appears to be doing nothing
    « Reply #9 on: February 13, 2019, 04:17:24 PM »
    No.  I've never actually needed to mod a formula myself, but it's easy enough to infer from FFTP's behavior that formula changes will not appear in the drop-down list.

    It was really the word anything that I took issue with. When I "Open patched ISO..." the changes I've made have always been read from the image & reflected in FFTP.  Indeed, even applying an ASM hack that overwrites propostion space results in altered prop values upon an ISO re-open.

    • Modding version: PSX
  • There are 10 kinds of people in the world; those who know binary, and those who don't.
    Go then. There are other worlds than these
    yamish [Posts: 31]
    • View Profile
    • share
    • [February 13, 2019, 04:39:01 PM]
    Re: FFTorgASM appears to be doing nothing [solved]
    « Reply #10 on: February 13, 2019, 04:39:01 PM »
    Confirmed working now.

    Thanks for the patch update Glain!
    Pages: [1]