Please login or register.

Login with username, password and session length
Advanced search  

News:

Please use .png instead of .bmp when uploading unfinished sprites to the forum!

Camera Rotation Issue  (Read 559 times)
Pages: [1]
mythosknight121 [Posts: 3]
  • View Profile
  • share
  • [February 04, 2019, 05:03:57 AM]
Camera Rotation Issue
« on: February 04, 2019, 05:03:57 AM »
Greetings all,

I seem to be having an issue with my camera rotation. I am using this:

Camera(+00784,+00000,+00784,+00302,-01536,+00000,+04096,+00080)
WaitForInstruction(x04,x00)

From my understanding the map should rotate around X:7 & Y:7.
Z axis should not change.
Angle will stay at 26.54 degrees.
It should rotate counter clockwise 135 degrees.
With 100% zoom.
In around 1.3 seconds.

Regardless if map rotation, MAPRT, is a positive or negative number, the rotation is clockwise and is taking the longest route to the new specified degree.

The example I listed is causing the camera to not rotate 135 degrees but 495 degrees.

What am I missing?

Thanks.
« Last Edit: February 04, 2019, 09:31:52 AM by mythosknight121 »
Nyzer [Posts: 973]
  • View Profile
  • share
  • [February 04, 2019, 05:09:21 AM]
Re: Camera Rotation Issue
« Reply #1 on: February 04, 2019, 05:09:21 AM »
You need to list your previous camera command too. Odds are you just have too much of a difference between your two command angles. That means there's a better rotation number to set the camera at.

Up to you whether you want to change that camera angle pr the previous one.

I always use the same four rotations so I don't normally come across this issue, but I did recently when I was using the Camera Helper in order to properly place the camera for Effects. I merely moved the X and Y a little and the camera was doing a 360 degree rotation. Setting up different angles fixed it.

    • Modding version: PSX & WotL
  • mythosknight121 [Posts: 3]
    • View Profile
    • share
    • [February 04, 2019, 05:12:54 AM]
    Re: Camera Rotation Issue
    « Reply #2 on: February 04, 2019, 05:12:54 AM »
    The event starts with this:
    {63}(rC9)
    Camera(+01000,+00000,+00615,+00302,+02560,+00000,+04096,+00001)
    Camera(+01000,+00000,+00615,+00302,+02560,+00000,+04096,+00001)
    {4D}(r78)
    Camera(+01000,+00000,+00615,+00302,+03584,+00000,+04096,+00300)
    WaitForInstruction(x04,x00)

    And about halfway I have this:
    {63}(rAA)
    Focus(x02,x00,x02,x00,x00)
    Camera(+00001,+01253,+04352,+00302,+00512,+00000,+04096,+0100)
    WaitForInstruction(x04,x00)

    They are copy and pasted from Elric's awesome tutorial. Just modified the timing.
    Nyzer [Posts: 973]
    • View Profile
    • share
    • [February 06, 2019, 06:06:14 PM]
    Re: Camera Rotation Issue
    « Reply #3 on: February 06, 2019, 06:06:14 PM »
    Look at the differences between your Map Rotations across all three commands. There's a lot of difference.

    On top of that the Focus command will cause your Camera instruction to selectively ignore certain parts as it sees fit. Unsure if Map Rotation is one of those but it could be.

    • Modding version: PSX & WotL
  • French Maid
    Xifanie (Webmistress) [Posts: 4427]
    • View Profile
    • Final Fantasy Hacktics
    • http://steamcommunity.com/id/Xifanie
    • share
    • [February 07, 2019, 08:25:50 PM]
    Re: Camera Rotation Issue
    « Reply #4 on: February 07, 2019, 08:25:50 PM »
    It's always better to stick to pure camera instruction for events because otherwise with focus following a camera instruction, the camera might spin 315 degrees one side instead of 45 degrees the other.

    Unfortunately I don't know the mechanics in details about this.

    • Modding version: PSX
  • <R999> My target market is not FFT mod players
    <Raijinili> remember that? it was awful
    Pages: [1]