Please login or register.

Login with username, password and session length
Advanced search  

News:

Please use .png instead of .bmp when uploading unfinished sprites to the forum!

Help with sprite please  (Read 349 times)
Pages: [1]
IsaacMG [Posts: 9]
  • View Profile
  • share
  • [January 11, 2017, 02:39:45 PM]
Help with sprite please
« on: January 11, 2017, 02:39:45 PM »
(So, I'm making my custom sprite and it's type two. When I see its animations in the shishi sprite editor, the arms move right when it's set in type two, but they move in the game as if they were set in type one, buggy and out of place. What is happening????

EDIT: I'm using ppsspp to test the sprite, but it should be ok right?)

Ok whatever, it was the emulator. I'm finishing this sprite and I would like to know how can I get the portrait better. And also, more important in fact, why does the back of the portrait display in brown in shishi. I'm using Graphics Gale, the more information the better I guess.

By the way, what do you think about it? is it nice enough to pass through the quality filter? (apart from the portrait of course)
« Last Edit: January 13, 2017, 04:37:06 PM by IsaacMG »
    • Modding version: WotL
  • IsaacMG [Posts: 9]
    • View Profile
    • share
    • [January 13, 2017, 04:40:19 PM]
    Re: Help with sprite please
    « Reply #1 on: January 13, 2017, 04:40:19 PM »
    I've edited the main problem, would you mind helping? Thanks  :D
    Ranting and Raving
    CodySpie [Posts: 55]
    • View Profile
    • Game Grit - Modern Tech
    • http://steamcommunity.com/id/cptsharppz/
    • share
    • [January 13, 2017, 06:58:36 PM]
    Re: Help with sprite please
    « Reply #2 on: January 13, 2017, 06:58:36 PM »
    Right away I see that your portrait has no background. When you're making a sprite, your Palette will be split into two rows. The first row is your Sprite palette, your ninth row is your Portrait palette. The first color in your portrait palette has to be your portrait background, or you'll see a lot of problems in-game.

    I've attached a Portrait with the background just to give you an idea. It's RGB Values has to be set to 168, 160, 136


    • Modding version: PSX
  • Nyzer [Posts: 678]
    • View Profile
    • share
    • [January 13, 2017, 06:58:58 PM]
    Re: Help with sprite please
    « Reply #3 on: January 13, 2017, 06:58:58 PM »
    You're using the first palette for the portrait when the portrait uses the ninth palette in FFT.

    Also, Type2 can be wonky on PSP. Only put T2 sprites in previously established T2 slots.

    • Modding version: PSX & WotL
  • IsaacMG [Posts: 9]
    • View Profile
    • share
    • [January 13, 2017, 09:42:24 PM]
    Re: Help with sprite please
    « Reply #4 on: January 13, 2017, 09:42:24 PM »
    Ok I'll try to solve it. Thanks to you both for the tips!!!  :D I'll let you know if I have any issue.
    Pages: [1]