Please login or register.

Login with username, password and session length
Advanced search  

News:

Don't be hasty to start your own mod; all our FFT modding projects are greatly understaffed. Find out how you can help in the Recruitment section.

Pages: [1]
C1REX [Posts: 15]
  • View Profile
  • share
  • [June 04, 2017, 01:00:25 AM]
Problem with hit animation/damage display.
« on: June 04, 2017, 01:00:25 AM »
I'm changing Knight job so it can strike magic at close range.
I try to make it Bolt at range 1. The game displays damage at the beginning when Knight strikes his sword and then again after end of bolt animation. Looks like double damage and no idea what I'm doing wrong.

C1REX [Posts: 15]
  • View Profile
  • share
  • [June 04, 2017, 06:47:25 PM]
Re: Problem with hit animation/damage display.
« Reply #1 on: June 04, 2017, 06:47:25 PM »
OK. I know the problem but don't know the solution.

I wanted to make Knight something like Holy Knights but using Bolt 3, Ice3 etc at close range only. This would replace all break skills.

If I create the custom skills by modifying Holy Knight skills then all is good - just new animation appears.
When I do the same by modifying brake weapon skill for example the damage in shown twice - once on sword hit and once after full spell animation.

I've seen similar issue on 1.3 patch as well so I'm not the only one.

I've checked animation tab and both break and holy sword skill have 07. 00. 00. I have no idea what makes them different and how to have more  new Sword skills without the problem.
nyzer [Posts: 656]
  • View Profile
  • share
  • [June 04, 2017, 08:20:17 PM]
Re: Problem with hit animation/damage display.
« Reply #2 on: June 04, 2017, 08:20:17 PM »
It's not just the Animation tab. There are a lot of flags in the Abilities tab, and you're probably overlooking something.

Same thing for your topic from earlier about having units joining as guests. You've got something flagged that you shouldn't.
C1REX [Posts: 15]
  • View Profile
  • share
  • [June 04, 2017, 09:44:11 PM]
Re: Problem with hit animation/damage display.
« Reply #3 on: June 04, 2017, 09:44:11 PM »
I couldn't find the problem so I edited an unnamed skill. I did the same copy/paste and it works just fine now. I may be blind but can't see what the problem was - all flags look fine.

Still learning how to use the tool.
« Last Edit: June 04, 2017, 10:25:56 PM by C1REX »
    • Modding version: Other/Unknown
  • nyzer [Posts: 656]
    • View Profile
    • share
    • [June 07, 2017, 03:16:32 PM]
    Re: Problem with hit animation/damage display.
    « Reply #4 on: June 07, 2017, 03:16:32 PM »
    I'd suggest posting screenshots of the relevant Patcher tabs if you're looking for help with stuff like this - then we can easily see if you've missed something you shouldn't have.
    Pages: [1]