Final Fantasy Hacktics

Modding => Help! => Topic started by: yamish on February 11, 2019, 09:26:36 PM

Title: FFTorgASM appears to be doing nothing [solved]
Post by: yamish on February 11, 2019, 09:26:36 PM
I am using the latest version of the Patcher Suite.
I am modding the PSX version.
The ISO being used is a bin/cue that i confirmed as usable via md5 against the thread that lists md5s
The ISO is not read only
FFTPatcher successfully patches the ISO
FFTorgASM has been run regularly and with admin privileges

When using FFTorgASM to attempt to apply patches, nothing happens. They are selected, bin is selected, no confirmation nor error messages nor anything when clicking to apply it. Open up the iso in FFTPatcher to see if formula 11 is no longer blank (what im using to quickly see if it is succeeding) and it remains blank.

I've looked everywhere and can't find a single thing I'm missing or have done wrong. Any insights into this?
Title: Re: FFTorgASM appears to be doing nothing
Post by: Glain on February 11, 2019, 10:15:09 PM
The formula labels in FFTPatcher don't read anything from the actual formula code in the game, so that doesn't work as a quick test.  :D

You'll have to try testing the behavior in-game.

Generically, you can also see whether or not the timestamp updates on the BIN file when you apply a patch.
Title: Re: FFTorgASM appears to be doing nothing
Post by: yamish on February 12, 2019, 01:11:52 AM
Ah, i thought if i opened the iso itself it would show the formula. Thanks for clearing that up.

And i didn't check timestamp cause...ok look i smoked a lot today

So FFTorgASM gives no success/fail message upon tunning?
Title: Re: FFTorgASM appears to be doing nothing
Post by: Nyzer on February 12, 2019, 04:52:06 AM
FFTP has basically never drawn anything from the ISO; I learned that a long time ago just from modding my own personal patch. Always had to keep a note of what IDs were what changed skillset or name or whatever.
Title: Re: FFTorgASM appears to be doing nothing
Post by: yamish on February 12, 2019, 08:24:36 PM
Using epsxe for android

Ok so it appears FFTorgASM doesn't give any kind of indication that has successfully applied anything.

I applied two ASM hacks, the one that changes formula 11 to MA*(WP+Y) and the one that says All formulas apply element (v2)

This is the only modification thus far.

All goes well with opening sequence, Gaf and Agr converse, then when Gaf goes to take his first turn, epsxe crashes. Behavior is normal with an a unaltered iso.

Are one of these reliant on another ASM hack to be in place? Is there a list somewhere of conflicting ASM hacks that aren't readily apparent? Am I just dumb?
Title: Re: FFTorgASM appears to be doing nothing
Post by: Glain on February 13, 2019, 01:05:30 AM
That should have worked.  It turns out... there was a bug in my elemental hack!  Thanks for reporting the issue.  I've fixed the problem and uploaded a new zip in my ASM thread (http://ffhacktics.com/smf/index.php?topic=7864.0).
Title: Re: FFTorgASM appears to be doing nothing
Post by: yamish on February 13, 2019, 04:27:56 AM
Awesome! I'll give it a go tomorrow and report back.
Title: Re: FFTorgASM appears to be doing nothing
Post by: Nizea on February 13, 2019, 02:31:59 PM
FFTP has basically never drawn anything from the ISO

This does not match my experience.

Perhaps it was true for old Patcher versions prior to my FFT-hacking days...
Have you continued to verify this behavior as new versions were released?
Title: Re: FFTorgASM appears to be doing nothing
Post by: Nyzer on February 13, 2019, 03:26:06 PM
Are you saying that when you put custom formulas in the Patcher automatically reads the change and reports it correctly?
Title: Re: FFTorgASM appears to be doing nothing
Post by: Nizea on February 13, 2019, 04:17:24 PM
No.  I've never actually needed to mod a formula myself, but it's easy enough to infer from FFTP's behavior that formula changes will not appear in the drop-down list.

It was really the word anything that I took issue with. When I "Open patched ISO..." the changes I've made have always been read from the image & reflected in FFTP.  Indeed, even applying an ASM hack that overwrites propostion space results in altered prop values upon an ISO re-open.
Title: Re: FFTorgASM appears to be doing nothing [solved]
Post by: yamish on February 13, 2019, 04:39:01 PM
Confirmed working now.

Thanks for the patch update Glain!